I am not sure what causes this issue, but I have been able to recreate a workaround to this problem. Sometimes the accept button simply does not register that I have clicked it. The only way that I have been able to work around this problem is clicking the "Ask Question" button on the top, then clicking the back button on my browser. When click the accept button again, behold, the check mark becomes green with the answer accepted.

Other info

  • Running Windows XP Pro
  • Browser is IE 8
  • Other buttons work like "This is a favorite question."
  • Refreshing the page does not work to this problem.

Example 1 ServerFault

Example 2 SuperUser

  • 1
    There is a timer (minimum question age) that needs to run out before you can accept answers - I don't recall the value but it's not terribly long. If the answers are popping up quick are you sure you're not running afoul of that?
    – voretaq7
    Commented Sep 27, 2011 at 17:17
  • 1
    These were days old questions from both the SuperUser and ServerFault sites. The only other peice of information I can think of is that I answered my own questions. It was weird that I was experiencing the exact same problem on two seperate questions at the same time. Thats how I was able to test the workaround method given in the question. Commented Sep 27, 2011 at 18:08
  • hmm, that definitely sounds buggy - Does it happen in another browser (chrome, firefox, safari) too, or is it IE8-specific brokenness?
    – voretaq7
    Commented Sep 27, 2011 at 18:32
  • Not sure, it was a unique instance that I was able take advantage of to test, and I happen to be in IE8 when it happened. Commented Sep 27, 2011 at 18:35
  • 1
    The Question needs to be 48 hours old before you can Accept your own answer. An Answer must be 10 minutes old before you can Accept it.
    – Chris S
    Commented Sep 28, 2011 at 15:27
  • Experiencing the problem again as of now on another question. Again, can't figure out what is causing. I am in IE9 now. Not sure its related, but this time I also got an orange box saying "An error has occured. Click this box to dismiss" right below where the the check mark exists. Adding this for documentation purposes. Commented Sep 30, 2011 at 19:22
  • Used the work around to accept. Doesn't allow me to toggle back off until I use the work around again. Commented Sep 30, 2011 at 19:24
  • @hydroparadise take a look at this meta.serverfault.com/questions/1866/stackexchange-link-error It sounds like you might be having something similar to that. Try waiting a while for the page to finish loading and see if that helps.
    – Nixphoe
    Commented Oct 1, 2011 at 13:22

1 Answer 1


We can't reproduce this, and have no other reports of it at this time.

  • This has happened more than once before. Is there anything I can do to gather information when this problem happens again? Commented Sep 28, 2011 at 14:01
  • 1
    @hydroparadise find out what steps it takes to reliably reproduce the issue.
    – Nixphoe
    Commented Sep 28, 2011 at 18:12
  • Ok, so it happens in FireFox 7, IE8 and IE9. However, I have been able to reproduce the problem reliably. If I disable my network apapter before accepting an answer, that will most certain recreate the behavior. The only thing that has remained constant in this whole thing is the network from which I am corresponing from with a well guarded firewall. Commented Sep 30, 2011 at 20:24
  • 1
    @hydro if you disable your network adapter, all bets are off. That's not a repro, that's "when I crash my car into a wall, it is damaged." Commented Oct 1, 2011 at 3:21
  • Thats what I was getting at. The button depends on sending and receiving packets to work. In a since, I was blaming my network firewall, not SF. Thanks for taking the time. Commented Oct 3, 2011 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .