1

While responding to a question on ServerFault I noticed that there seems to be a bug in the display code.

Using Bold (**) and Italic (*) at the same time shows up correctly as bolded italic text in the preview but on the post itself. The post itself will show up as bolded text with *'s on both sides.

Perhaps I'm doing something wrong? It explicitly says that it should work in the full format reference on the right side of the page and it does display correctly in the preview. I did not try using underscores.

migrated from meta.stackoverflow.com Jul 22 '10 at 18:07

This question came from our discussion, support, and feature requests site for professional and enthusiast programmers.

  • It did show up correctly here so perhaps it is just serverfault? The post in question can be found here: serverfault.com/questions/90676/… Those with the ability to edit other's posts can roll back the revision on my post to see what I'm talking about – TrueDuality Dec 3 '09 at 16:32
  • errrr... looks correct to me – Jeff Atwood Dec 3 '09 at 16:32
  • 1
    You edited your post fast enough that there isn't any revision to look at. – mmyers Dec 3 '09 at 16:33
  • By design - nothing is so important that it should both be bold and italic. Choose one or the other, but not both. And please, choose wisely! – Pollyanna Dec 3 '09 at 18:07
3

I've managed to reproduce this:

it seems that simple text works

but,

underscores_screw_everything_up

(view source for details)

My guess is that this is somehow connected to the change that SO made to Markdown such that underscores no longer trigger italics when used within_a_word...

1

We disable intra-word markdown emphasis on the server, but it still shows in the preview.

This is by design at the moment.

If you need finer control use <b> and <i> as appropriate

  • 1
    In this case, the user wasn't actually after intra-word formatting; he just happened to be formatting words that would normally have been interpreted that way by non-SO Markdown engines. – Shog9 Dec 3 '09 at 16:49

You must log in to answer this question.