8

Stack Overflow all fine, SuperUser all fine, even meta all fine, but Serverfault frequently just 'gives up' in Safari 4.

I've tried it from 2 up-to-date Mac OS X machines, in both Safari and Firefox, and it seems really hit and miss - I've cleared the caches and restarted both browsers, but I can't seem to find the problem. The 'sister' sites are all working fine but ServerFault just doesn't want to load. From the activity log in Safari, it looks like it times-out with this;

http://serverfault.com/content/js/master.js?v=3731

this just doesn't ever seem to finish loading. Any thoughts? This has been a problem at both my office and at home, so I've no reason to believe it's a broadband issue (though to be fair it's the same provider at both locations).

edit: I've tried it on 2 machines, both browsers, 2 physical locations, so 8 permutations. I'll try to get more diagnostic information and run on a few more permutations.

migrated from meta.stackoverflow.com Jul 22 '10 at 18:07

This question came from our discussion, support, and feature requests site for professional and enthusiast programmers.

  • The same happens me too for SO sometimes. Your geo-location seem to be one reason. This suggests me that the trouble is specific to the users-per-server -ratio. – Masi Jul 18 '09 at 15:41
  • downforeveryoneorjustme.com/serverfault.com – esm Jul 18 '09 at 16:53
  • The issue appears to be DNS based, not a serverfault – Cian Jul 18 '09 at 17:31
  • please see meta.stackexchange.com/questions/7070/… – Jeff Atwood Jul 19 '09 at 12:04
  • Ooh, in a way I'm oddly glad that it's not just my Macs/Safari etc. The fact that the 3 sister sites seemed to be fine did cause me to doubt it was a problem specifically at /my/ end. Fingers crossed the network experts can get it all working again. :-) – robsoft Jul 19 '09 at 15:31
5

Can't seem to connect to serverfault at all - seems to be DNS issue.

$ dig +short @208.67.222.222  stackoverflow.com
69.59.196.211

$ dig +short @208.67.222.222  meta.stackoverflow.com
69.59.196.213

$ dig +short @208.67.222.222  superuser.com
69.59.196.219

$ dig @208.67.222.222  serverfault.com

; <<>> DiG 9.6.1-RedHat-9.6.1-2.fc11 <<>> @208.67.222.222 serverfault.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 16033
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;serverfault.com.       IN  A

;; Query time: 12 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Sat Jul 18 16:38:59 2009
;; MSG SIZE  rcvd: 33

$ dig @ns22.domaincontrol.com serverfault.com

; <<>> DiG 9.4.2-P2 <<>> @ns22.domaincontrol.com serverfault.com
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58675
;; flags: qr aa; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;serverfault.com.               IN      A

;; ANSWER SECTION:
serverfault.com.        3600    IN      A       69.59.196.212

;; AUTHORITY SECTION:
serverfault.com.        3600    IN      NS      ns21.domaincontrol.com.
serverfault.com.        3600    IN      NS      ns22.domaincontrol.com.

;; Query time: 81 msec
;; SERVER: 208.109.255.11#53(208.109.255.11)
;; WHEN: Sat Jul 18 23:20:00 2009
;; MSG SIZE  rcvd: 101

I still can't get this from any other dns server... I've put it in /etc/hosts for now

3
ping serverfault.com
ping: unknown host serverfault.com

in Slovenia.

2

Can't repro -- just browsed a bunch in Safari 4 on SF and not seeing any issues.

  • Thanks Jeff. I'll try it on a few different machines and connections, and try to get some more diagnostic information. – robsoft Jul 18 '09 at 14:09
1

Oddly enough, when I try to dig from stackoverflow's nameserver, from a UPC connection in .ie, I get no answer:

; <<>> DiG 9.5.1-P2 <<>> @216.69.185.11 serverfault.com ; (1 server found) ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 552 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION: ;serverfault.com. IN A

;; Query time: 8 msec ;; SERVER: 216.69.185.11#53(216.69.185.11) ;; WHEN: Sun Jul 19 12:11:23 2009 ;; MSG SIZE rcvd: 33

When I try the exact same thing from a box in France (on ovh), I get an answer

; <<>> DiG 9.4.2-P2 <<>> @216.69.185.11 serverfault.com ; (1 server found) ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33998 ;; flags: qr aa; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION: ;serverfault.com. IN A

;; ANSWER SECTION: serverfault.com. 3600 IN A 69.59.196.212

;; AUTHORITY SECTION: serverfault.com. 3600 IN NS ns21.domaincontrol.com. serverfault.com. 3600 IN NS ns22.domaincontrol.com.

;; Query time: 83 msec ;; SERVER: 216.69.185.11#53(216.69.185.11) ;; WHEN: Sun Jul 19 12:11:05 2009 ;; MSG SIZE rcvd: 101

I get similar data from other nameservers, so I think UPC must be silently redirecting DNS requests. Out of interest, how many of the other users suffering from this are on UPC?

1

I'm in Sweden and I get the same problem.

> dig serverfault.com                        

; <<>> DiG 9.5.1-P1 <<>> serverfault.com
;; global options:  printcmd
;; connection timed out; no servers could be reached

> dig stackoverflow.com                      

; <<>> DiG 9.5.1-P1 <<>> stackoverflow.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57515
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;stackoverflow.com.             IN      A

;; ANSWER SECTION:
stackoverflow.com.      4507    IN      A       69.59.196.211

;; AUTHORITY SECTION:
stackoverflow.com.      134614  IN      NS      ns52.domaincontrol.com.
stackoverflow.com.      134614  IN      NS      ns51.domaincontrol.com.

;; ADDITIONAL SECTION:
ns51.domaincontrol.com. 3166    IN      A       216.69.185.26
ns52.domaincontrol.com. 3166    IN      A       208.109.255.26

;; Query time: 0 msec
;; SERVER: 10.0.0.1#53(10.0.0.1)
;; WHEN: Sun Jul 19 14:32:48 2009
;; MSG SIZE  rcvd: 135
1

Finland here, also no reach to serverfault.com

$ dig serverfault.com

; <<>> DiG 9.5.1-P2 <<>> serverfault.com
;; global options:  printcmd
;; connection timed out; no servers could be reached

There is my attempt going to get a woot badge on all sites.

You must log in to answer this question.